OSS Index data is being upgraded. There are some breaking changes.
Learn more
Sonatype DepShield will be deprecated soon. Please install our new product, Sonatype Lift, with advanced features.
 Try Lift for free

Description

A RAII scope guard that will run a given closure when it goes out of scope, even if the code between panics (assuming unwinding panic). Defines the macros `defer!` and `defer_on_unwind!`; the latter only runs if the scope is extited through unwinding on panic.

Vulnerabilities

No vulnerabilities detected

Did You Know?

Sonatype Lift installs as a Github app to automatically flag vulnerabilities on every pull request, and reports findings as comments in code review. Lift catches high-risk issues and screens out likely false-positives, helping you fix the things you care about most. See what Lift finds in your project.

Sign up and see:

Detailed component information including:
  • Version history
  • Declared licenses
  • Vulnerability details
Sign Up